Tag Archives: Eclipse

Running Solr 4.10.3 with Maven, Eclipse 4.4 and Wildfly 8.1.0

The basic setup of Solr 4.10 with Eclipse 4.4 and Wildfly 8.1 requires quite a bit of configuration. First of all, be sure that your system fulfills the following requirements.

Prerequisites

  • Java Development Kit (jdk1.8.0_25)
  • Eclipse Java EE IDE for Web Developers (Luna Service Release 1 (4.4.1))
  • Apache Maven (already included in Eclipse)
  • WildFly Application Server (wildfly-8.1.0.Final)
  • JBossAS Tools (3.0.0.CR1) for Eclipse)

The specified version numbers are the versions I’m using. The tutorial should however apply to other major versions, too.

Continue reading